WordPress Profile Builder plugin sérülékenységei

CH azonosító

CH-6899

Angol cím

WordPress Profile Builder Plugin Multiple Vulnerabilities

Felfedezés dátuma

2012.05.22.

Súlyosság

Közepes

Érintett rendszerek

Profile Builder Plugin
WordPress

Érintett verziók

WordPress Profile Builder Plugin 1.x

Összefoglaló

A WordPress Profile Builder plugin sérülékenységei váltak ismertté, amelyek közül az egyik ismeretlen hatású, míg a másikat a támadók kihasználhatják bizonyos biztonsági szabályok megkerülésére.

Leírás

  1. A front-end/wppb.recover.password.php “key” paraméterének a megjósolható generálása kihasználható a jelszó módosító funkcióhoz való hozzáférésre és ezáltal tetszőleges felhasználó jelszavának megváltoztatására
    A sérülékenység sikeres kihasználásához a felhasználó nevének és azonosítójának az ismeretére van szükség.
    A sérülékenység az 1.1.24 verziót érinti, de más kiadások is érintettek lehetnek.
  2. Néhány nem részletezett hiba jelentettek, amikről a jelenleg további információ nem elérhető.
    Ez a sérülékenység az 1.1.25 előtti verziókat érinti.

Megoldás

Frissítsen a legújabb verzióra