WordPress s2Member Pro bővítmény “Coupon Code” cross-site scripting sérülékenység

CH azonosító

CH-6397

Angol cím

WordPress s2Member Pro Plugin "Coupon Code" Cross-Site Scripting Vulnerability

Felfedezés dátuma

2012.02.13.

Súlyosság

Alacsony

Érintett rendszerek

WordPress
s2Member plugin

Érintett verziók

WordPress s2Member Pro bővítmény

Összefoglaló

Az s2Member Pro WordPress bővítmény olyan sérülékenysége vált ismertté, amelyet a támadók kihasználhatnak cross-site scripting (XSS/CSS) támadások kezdeményezésére.

Leírás

A Coupon Code paraméterrel átadott bemeneti adat nem kerül megfelelően ellenőrzésre, mielőtt a felhasználó részére visszaküldésre kerülne. Ez kihasználható a felhasználó böngészőjének munkamenetében történő tetszőleges HTML és script kód futtatására, az érintett oldallal kapcsolatosan.

A sérülékenységet a 111220. megelőző verziókban ismerték fel.

Megoldás

Frissítsen a legújabb verzióra