WordPress Sentinel Plugin cross-site scripting és cross-site request forgery sérülékenységek

CH azonosító

CH-6114

Angol cím

WordPress Sentinel Plugin Cross-Site Scripting and Cross-Site Request Forgery Vulnerabilities

Felfedezés dátuma

2011.12.15.

Súlyosság

Alacsony

Érintett rendszerek

Sentinel plugin
WordPress

Érintett verziók

WordPress Sentinel plugin 1.0.0

Összefoglaló

A WordPress Sentinel moduljának sérülékenységeit jelentették, melyeket a támadók kihasználhatnak cross-site scripting (CSS/XSS) és cross-site request forgery (CSRF/XSRF) támadások indítására.

Leírás

  1. A dashboard-dal kapcsolatos bizonyos bemenet nincs megfelelően ellenőrizve, mielőtt visszaadnák a felhasználóknak. Ez kihasználható tetszőleges HTML és script kód lefuttatására a felhasználó böngészői munkamenetében, az érintett oldallal kapcsolatosan.
  2. Az alkalmazás lehetővé teszi a felhasználóknak bizonyos műveletek végrehajtását HTTP kéréseken keresztül anélkül, hogy ellenőrizné azok érvényességét. Ez kihasználható pl. pillanatfelvételek készítésére, ha egy adminisztrátorként bejelentkezett felhasználó ellátogat egy speciálisan erre a célra elkészített weboldalra.

Megoldás

Frissítsen a legújabb verzióra