WordPress SFBrowser Plugin fájl feltöltés sérülékenysége

CH azonosító

CH-6992

Angol cím

WordPress SFBrowser Plugin Arbitrary File Upload Vulnerability

Felfedezés dátuma

2012.06.10.

Súlyosság

Magas

Érintett rendszerek

SFBrowser Plugin
WordPress

Érintett verziók

WordPress SFBrowser Plugin 1.x

Összefoglaló

A WordPress SFBrowser Plugin sérülékenysége vált ismertté, amelyet kihasználva a támadók feltörhetik a sérülékeny rendszert.

Leírás

A sérülékenység oka, hogy a wp-content/plugins/sfbrowser/connectors/php/sfbrowser.php script nem megfelelően ellenőrzi a feltöltött fájlokat. Ez kihasználható tetszőleges PHP kód futtatására egy tetszőleges fájlnév kiterjesztéssel ellátott PHP fájl feltöltésével.

A sérülékenységet az 1.4.5 verzióban jelentették, de egyéb kiadások is érintettek lehetnek.

Megoldás

Korlátozza a wp-content/plugins/sfbrowser/connectors/php/sfbrowser.php scripthez történő hozzáférést (pl. a .htaccess használatával)!