WordPress Social Media Widget bővítmény script beszúrásos sérülékenység

CH azonosító

CH-8948

Angol cím

WordPress Social Media Widget Plugin Compromised Source Package Script Insertion Security Issue

Felfedezés dátuma

2013.04.15.

Súlyosság

Alacsony

Érintett rendszerek

Social Media Widget Plugin
WordPress

Érintett verziók

WordPress Social Media Widget Plugin 3.x, 4.x

Összefoglaló

A WordPress Social Media Widget bővítmény sérülékenysége vált ismertté, amelyet kihasználva a támadók script beszúrásos (script insertion) támadásokat hajthatnak végre.

Leírás

A sérülékenység oka a kompromittált, káros kódot tartalmazó Social Media Widget plugin forráskód csomagok terjesztése, ami kihasználható pl. tetszőleges HTML és script kód beszúrására, ami a felhasználó böngészőjének munkamenetében fog végrehajtódni, az érintett oldallal kapcsolatban.

A kompromittált forráskód fájlok a 2013-04-11 előtti 3.1, 3.2 és 3.3 valamint a 4.0 verzióban találhatók.

Megoldás

Frissítsen a legújabb verzióra