WordPress SQL befecskendezéses sérülékenység

CH azonosító

CH-3999

Angol cím

WordPress SQL Injection Vulnerability

Felfedezés dátuma

2010.11.30.

Súlyosság

Alacsony

Érintett rendszerek

WordPress

Érintett verziók

WordPress 3.x

Összefoglaló

Egy sérülékenységet jelentettek a WordPress-ben, amelyet kihasználva rosszindulatú felhasználók SQL befecskendezéses támadásokat hajthatnak végre.

Leírás

Bizonyos adatbevitel a wp-includes/comment.php-ban nincs megfelelően ellenőrizve, mielőtt SQL lekérdezésekben használnák. Ez kihasználható az SQL lekérdezések módosítására tetszőleges kód befecskendezésével.

A sikeres kihasználásához “Author” jogosultság szükséges.

A sérülékenységet a 3.0.2 verziót megelőző kiadásokban jelentették.

Megoldás

Frissítsen a legújabb verzióra