WordPress The Guardian News Feed bővítmény sérülékenysége

CH azonosító

CH-7165

Angol cím

WordPress The Guardian News Feed Plugin Cross-Site Request Forgery Vulnerability

Felfedezés dátuma

2012.07.09.

Súlyosság

Alacsony

Érintett rendszerek

The Guardian News Feed Plugin
WordPress

Érintett verziók

WordPress The Guardian News Feed Plugin 0.x

Összefoglaló

A WordPress The Guardian News Feed bővítményének sérülékenységét jelentették, amelyet a támadók kihasználhatnak cross-site request forgery (XSRF/CSRF) támadások indítására.

Leírás

Az alkalmazás lehetővé teszi a felhasználóknak bizonyos műveletek elvégzését HTTP kérések segítségével anélkül, hogy ellenőrizné azok érvényességét. Ez kihasználható például script beszúrásos (script insertion) támadások végrehajtására, ha a bejelentkezett adminisztrátor ellátogat egy speciálisan elkészített web oldalra.

A sérülékenységet a 0.4.2 verziónál korábbiakban jelentették.

Megoldás

Frissítsen a legújabb verzióra