WordPress TheCartPress Plugin “tcp_name_post_1” cross-site scripting sérülékenység

CH azonosító

CH-6179

Angol cím

WordPress TheCartPress Plugin "tcp_name_post_1" Cross-Site Scripting Vulnerability

Felfedezés dátuma

2012.01.01.

Súlyosság

Alacsony

Érintett rendszerek

TheCartPress plugin
WordPress

Érintett verziók

WordPress TheCartPress Plugin 1.x

Összefoglaló

A WordPress TheCartPress bővítményének olyan sérülékenységét fedezték, amelyet a támadók kihasználhatnak cross-site scripting (XSS/CSS) támadásokra.

Leírás

Az admin/OptionsPostsList.php “tcp_name_post_1” paraméterének átadott bemeneti adat nincs megfelelően ellenőrizve (ha a “tcp_options_posts_update” be van állítva és a “tcp_post_ids[]” értéke “1”), mielőtt visszaadnák azt a felhasználónak.
Ez kihasználható tetszőleges HTML és script kód lefuttatására, a felhasználó böngészőjének munkamenetében, az érintett oldallal kapcsolatosan.

A sérülékenységet az 1.1.5 verzióban igazolták, valamint az 1.1.6 verzió 2011.12.31-nél korábban letöltött verzióiban jelentették. Korábbi verziók is érintettek lehetnek.

Megoldás

Frissítsen a legújabb verzióra