WordPress Uploader bővítmény sérülékenységek

CH azonosító

CH-8615

Angol cím

WordPress Uploader Plugin Cross-Site Scripting and Arbitrary File Upload Vulnerabilities

Felfedezés dátuma

2013.03.03.

Súlyosság

Magas

Érintett rendszerek

Uploader plugin
WordPress

Érintett verziók

WordPress Uploader Plugin 1.x

Összefoglaló

A WordPress Uploader több sérülékenységét jelentették, amiket kihasználva a támadók cross-site scripting (XSS/CSS) támadásokat hajthatnak végre, valamint feltörhetik a sérülékeny rendszert.

Leírás

  1. A wp-content/plugins/uploader/views/notify.php részére a “blog” GET paraméterrel átadott bemeneti adat nincs megfelelően megtisztítva, mielőtt visszakerülne a felhasználóhoz. Ezt kihasználva, tetszőleges HTML és script kódot lehet futtatni a felhasználó böngészőjének munkamenetében az érintett oldal vonatkozásában.
  2. A wp-content/plugins/uploader/uploadify/uploadify.php script lehetővé teszi, hogy tetszőleges kiterjesztésű fájlokat lehessen feltölteni a webroot-ban lévő könyvtárakba. Ezt kihasználva tetszőleges PHP fájlt lehet felölteni és futtatni.

A sérülékenységeket az 1.0.4 verzióban jelentették, de más kiadások is érintettek lehetnek.