WordPress Uploader plugin sérülékenységek

CH azonosító

CH-4251

Angol cím

WordPress Uploader Plugin Two Vulnerabilities

Felfedezés dátuma

2011.01.24.

Súlyosság

Magas

Érintett rendszerek

Uploader plugin
WordPress

Érintett verziók

WordPress Uploader Plugin 1.x

Összefoglaló

A WordPress Uploader plugin két olyan sérülékenysége vált ismertté, melyet kihasználva támadók cross-site scripting (XSS/CSS) támadásokat tudnak végrehajtani és feltörhetik a sérülékeny rendszert.

Leírás

  1. A “num” paraméterrel a wp-content/plugins/uploader/views/notify.php-nek átadott bemenet nincs megfelelően ellenőrizve, mielőtt visszakerül a felhasználóhoz. Ez kihasználható tetszőleges HTML és script kód futtatására a felhasználó böngésző munkamenetében az érintett oldallal kapcsolatosan.
  2. A wp-content/plugins/uploader/uploadify/uploadify.php script lehetővé teszi tetszőleges kiterjesztésű fájl feltöltését a webrooton belüli könyvtárba. Ez kihasználható tetszőleges fájl feltöltésére a webrootba és többek között tetszőleges PHP kód futtatására.

A sérülékenység az 1.0.0. verzióban található, egyéb verziók is érintettek lehetnek.

Megoldás

Javítsa a forráskódot a bemenet megfelelő ellenőrzése érdekében! Korlátozza a hozzáférést a wp-content/plugins/uploader/uploadify/uploadify.php-hez (pl. .htaccess segítségével)!