WordPress UPM Polls plugin sérülékenység

CH azonosító

CH-5319

Angol cím

WordPress UPM Polls Plugin "qid" SQL Injection Vulnerability

Felfedezés dátuma

2011.08.07.

Súlyosság

Közepes

Érintett rendszerek

UPM Polls plugin
WordPress

Érintett verziók

WordPress UPM Polls Plugin 1.x

Összefoglaló

Az UPM Polls plugin for WordPress egy sérülékenységét jelentették, amelyet kihasználva a támadók SQL befecskendezéses (SQL injection) támadást indíthatnak.

Leírás

A wp-content/plugins/upm-polls/includes/poll_logs.php fájlban lévő “qid” változónak átadott bemeneti adat nem megfelelően van megtisztítva, mielőtt SQL lekérdezésben felhasználásra kerülne. Ezt kihasználható a az SQL kérések módosítására, tetszőleges SQL kód befecskendezésével.

A sérülékenységet az 1.0.3 verzióban jelentették, de egyéb kiadások is érintve lehetnek.

Megoldás

Frissítsen a legújabb verzióra