WordPress WassUp Plugin sérülékenység

CH azonosító

CH-6875

Angol cím

WordPress WassUp Plugin "User-Agent" HTTP Header Script Insertion Vulnerability

Felfedezés dátuma

2012.05.17.

Súlyosság

Közepes

Érintett rendszerek

WassUp Plugin
WordPress

Érintett verziók

WordPress WassUp Plugin 1.x

Összefoglaló

A WordPress WassUp Plugin olyan sérülékenysége vált ismertté, amelyet kihasználva a támadók script beszúrásos (script insertion) támadásokat tudnak végrehajtani.

Leírás

A “User-Agent” HTTP fejlécen keresztül átadott bemeneti adat nincsen megfelelően megtisztítva a használat előtt. Ezt kihasználva, tetszőleges HTML és script kódot lehet futtatni a felhasználó böngészőjének munkamenetében az érintett oldal vonatkozásában.

Megoldás

Frissítsen a legújabb verzióra