WordPress WP e-Commerce bővítmény script beszúrás sérülékenység

CH azonosító

CH-5991

Angol cím

WordPress WP e-Commerce Plugin Script Insertion Vulnerability

Felfedezés dátuma

2011.11.21.

Súlyosság

Közepes

Érintett rendszerek

WordPress
e-Commerce plugin

Érintett verziók

WordPress e-Commerce plugin 3.x

Összefoglaló

A WordPress WP e-Commerce bővítményének olyan sérülékenysége vált ismertté, amelyet a támadók kihasználhatnak script beszúrásos (script insertion) támadások kezdeményezésére.

Leírás

Egy termék kosárba helyezésekor a “custom_text” paraméterrel az index.php-nek átadott bemenet nem kerül megfelelően ellenőrzésre, mielőtt felhasználásra kerülne. Ez kihasználható az érintett oldal felhasználói böngésző munkamenetében történő tetszőleges HTML és script kód futtatására, amikor az rosszindulatú adat megtekintésre kerül.

A sérülékenység sikeresen kihasználható, amennyiben egyéni tartalom adható hozzá a vásárlásokhoz.

A sérülékenységet a 3.8.7.1. verzióban ismerték fel, de korábbi verziók is érintettek lehetnek.

Megoldás

Frissítsen a legújabb verzióra