WordPress WP e-Commerce nem részletezett SQL befecskendezéses sérülékenység

CH azonosító

CH-6300

Angol cím

WordPress WP e-Commerce Unspecified SQL Injection Vulnerability

Felfedezés dátuma

2012.01.22.

Súlyosság

Közepes

Érintett rendszerek

WordPress
e-Commerce plugin

Érintett verziók

WordPress e-Commerce plugin 3.x

Összefoglaló

A WordPress WP e-Commerce bővítményének olyan sérülékenységét jelentették, amelyet kihasználva a támadók SQL befecskendezéses támadást hajthatnak végre.

Leírás

Bizonyos nem részletezett bemenet nincs megfelelően ellenőrizve, mielőtt SQL lekérdezésekben felhasználnák. Ez kihasználható SQL lekérdezések manipulálására tetszőleges kód befecskendezésével.

A sérülékenységet a 3.8.7.6. verziónál korábbiakban jelentették.

Megoldás

Frissítsen a legújabb verzióra