WordPress WP e-Commerce Plugin “cart_messages[]” cross-site scripting sérülékenység

CH azonosító

CH-5307

Angol cím

WordPress WP e-Commerce Plugin "cart_messages[]" Cross-Site Scripting Vulnerability

Felfedezés dátuma

2011.08.03.

Súlyosság

Alacsony

Érintett rendszerek

WordPress
e-Commerce plugin

Érintett verziók

WordPress WP e-Commerce Plugin 3.x

Összefoglaló

A WordPress WP e-Commerce Plugin olyan sérülékenysége vált ismertté, amelyet kihasználva a támadók cross-site scripting (CSS/XSS) támadásokat tudnak végrehajtani.

Leírás

A “cart_messages[]” paraméternek átadott bemeneti adat a wp-content/plugins/wp-e-commerce/wpsc-theme/wpsc-cart_widget.php-ben nincs megfelelően megtisztítva a felhasználónak történő visszaadás előtt. Ez kihasználható tetszőleges HTML és script kód futtatására a felhasználó böngészőjének munkamenetében, az érintett oldallal kapcsolatosan.

A sérülékenység sikeres kihasználásának feltétele, hogy a “register_globals” engedélyezve legyen.

A sérülékenységet a 3.8.6-os verzióban jelentették. Más verziók is érintettek lehetnek.

Megoldás

Javítsa a forráskódot a bemenet megfelelő ellenőrzése érdekében