WordPress WP Photo Album bővítmény “id” cross-site scripting sérülékenység

CH azonosító

CH-4829

Angol cím

WordPress WP Photo Album Plugin "id" Cross-Site Scripting Vulnerability

Felfedezés dátuma

2011.04.27.

Súlyosság

Alacsony

Érintett rendszerek

WP Photo Album plugin
WordPress

Érintett verziók

WP Photo Album (WPPA) 1.x (WordPress bővítmény)

Összefoglaló

A WP Photo Album WordPress bővítmény olyan sérülékenysége vált ismertté, amelyet a támadók kihasználhatnak cross-site scripting (CSS/XSS) támadások okozására.

Leírás

A wp-admin/admin.php-ben az “id” paraméterrel átadott bemeneti adat (amikor “page” érétke “wp-photo-album/wppa.php” és “tab” értéke “del”) nem kerül megfelelően ellenőrzésre a wp-content/plugins/wp-photo-album/wppa.php-ben, mielőtt a felhasználó részére visszaküldésre kerülne. Ez kihasználható tetszőleges HTML és script kód futtatására a felhasználó böngészőjének munkamenetében, az érintett oldallal kapcsolatosan.

A sérülékenységet az 1.5.1. verzióban ismerték fel, de más verziók is érintettek lehetnek.

Megoldás

Javítsa a forráskódot a bemenet megfelelő ellenőrzése érdekében