WordPress wpcu3er plugin sérülékenység

CH azonosító

CH-5510

Angol cím

WordPress wpcu3er Plugin Arbitrary File Upload Vulnerability

Felfedezés dátuma

2011.09.06.

Súlyosság

Magas

Érintett rendszerek

WordPress
wpcu3er plugin

Érintett verziók

WordPress wpcu3er Plugin 0.x

Összefoglaló

A wpcu3er plugin for WordPress egy sérülékenységét jelentették, amelyet kihasználva a támadók feltörhetik a sérülékeny rendszert.

Leírás

A sérülékenységet az okozza, hogy a wp-content/plugins/wpcu3er/php/ajaxReq.php script nem megfelelően ellenőrzi a feltöltött állományok típusát. Ezt kihasználva tetszőleges PHP kódot lehet feltölteni.

A sérülékenységet a 0.55 verzióban jelentették, de egyéb kiadások is érintve lehetnek.

Megoldás

Frissítsen a legújabb verzióra