WordPress wpStoreCart Plugin fájl feltöltés sérülékenység

CH azonosító

CH-6973

Angol cím

WordPress wpStoreCart Plugin Arbitrary File Upload Vulnerability

Felfedezés dátuma

2012.06.10.

Súlyosság

Magas

Érintett rendszerek

WordPress
wpStoreCart Plugin

Érintett verziók

WordPress wpStoreCart Plugin 2.x

Összefoglaló

A WordPress wpStoreCart Plugin olyan sérülékenysége vált ismertté, amelyet kihasználva a támadók feltörhetik a sérülékeny rendszert.

Leírás

A sérülékenységet a wp-content/plugins/wpstorecart/php/upload.php script egy hibája okozza, amely lehetővé teszi fájlok feltöltését tetszőleges kiterjesztéssel egy webroot-on belüli könyvtárba. Ez kihasználható tetszőleges PHP kód futtatására kártékony PHP script feltöltésével.

A sérülékenység a 2.5.29 verzióban található, de korábbi kiadások is érintettek lehetnek.

Megoldás

Frissítsen a legújabb verzióra