WordPress ZenLite Theme “s” cross-site scripting sérülékenység

CH azonosító

CH-5689

Angol cím

WordPress ZenLite Theme "s" Cross-Site Scripting Vulnerability

Felfedezés dátuma

2011.10.03.

Súlyosság

Alacsony

Érintett rendszerek

WordPress
ZenLite theme

Érintett verziók

WordPress ZenLite Theme 4.x

Összefoglaló

A WordPress ZenLite téma olyan sérülékenysége vált ismertté, amelyet kihasználva a támadók cross-site scripting (CSS/XSS) támadásokat tudnak végrehajtani.

Leírás

Az “s” paraméteren keresztül az index.php részére átadott bemeneti adat nincsen megfelelően tisztázva a felhasználónak történő visszaadás előtt. Ez kihasználható tetszőleges HTML és script kód futtatására a felhasználó böngészőjének munkamenetében, az érintett oldallal kapcsolatosan.

A sérülékenységet a 4.3-as verzióban jelentették, megelőző verziók is érintettek lehetnek.

Megoldás

Frissítsen a 4.4-es verzióra.